Jump to content

MTA on OS X Mojave does not launch


Eagler

Recommended Posts

Hi there

I am trying to install MTA on my mac but it is not as simple as it should be. However, I managed to install SAMP and it was successful and easy. So the issue is not connected with GTA. I was using this instruction https://wiki.multitheftauto.com/wiki/MacOS#Making_Your_Own_Wrapper

The installation issue, solution is found

"The program dxwsetup.exe has encountered a serious problem and needs to close"

What I tried to do:

Unmarked directx installation, helped to complete installation, but when I am launching MTA, the problem occurs. 

Solution

The problem was solved by downloading custom wineskin. The installation was successful.

https://portingteam.com/topic/11037-unofficial-wineskin-project/

Launch issue

When I trying to open MTA it only shows a logo and closes immediately. Any ideas, or maybe MTA installer itself is broken. 

Solution

IDK

Any ideas?

Edited by Eagler
Link to post

WineSkin log 

fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:process:SetProcessShutdownParameters (00000380, 00000000): partial stub.
err:display:macdrv_ChangeDisplaySettingsEx No matching mode found 1920x1200x32 @60!
err:hid_report:process_hid_report Device reports coming in too fast, last report not read yet!
fixme:ole:CoInitializeSecurity (0x0,-1,0x0,0x0,0,3,0x0,0,0x0) - stub!
fixme:wbemprox:client_security_SetBlanket 0x48573b5c, 0x158db8, 10, 0, (null), 3, 3, 0x0, 0x00000000
fixme:wbemprox:client_security_Release 0x48573b5c
wine: Unhandled page fault on read access to 0x00000000 at address 0x6fca06 (thread 0009), starting debugger...
err:seh:start_debugger Couldn't start debugger ("false") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
wine: Unhandled page fault on read access to 0x43ab7b90 at address 0x4209d78f (thread 0032), starting debugger...
err:seh:start_debugger Couldn't start debugger ("false") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
 

Tried to change resolution 

fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:process:SetProcessShutdownParameters (00000380, 00000000): partial stub.
err:display:macdrv_ChangeDisplaySettingsEx No matching mode found 3840x2400x32 @60!
fixme:ole:CoInitializeSecurity (0x0,-1,0x0,0x0,0,3,0x0,0,0x0) - stub!
fixme:wbemprox:client_security_SetBlanket 0x46173b5c, 0x162d20, 10, 0, (null), 3, 3, 0x0, 0x00000000
fixme:wbemprox:client_security_Release 0x46173b5c
wine: Unhandled page fault on read access to 0x00000000 at address 0x6fca06 (thread 0009), starting debugger...
err:seh:start_debugger Couldn't start debugger ("false") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

Link to post
  • 2 weeks later...
  • 4 weeks later...
On 14/09/2020 at 02:38, qaisjp said:

Hi, did you read the warning at the top of the page? 

 

Support is one of the best in MTA, your slogan of support team should sounds like "do not ask questions for help, we dont give a :O"

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...