Jump to content

Recommended Posts

  • Moderators
21 minutes ago, Hades4 said:

This have cpu issues?

 

I am not sure, I don't have anybody that I can test it with. For hardware that can run basic GTA properly, it should be fine.

If anybody that has an old computer, I would be very happy if that person could make a benchmark.

Link to comment
  • Moderators
59 minutes ago, aka Blue said:

Nice! But I will use it only for screenshots or similar because with all that timers and checks I think that it will be fatal for potato PC's.

That part is only used for the initialization (loading the lowLOD objects). When that is over, there will be hardly any Lua activity what so ever except for the break-able objects. I highly recommend to check how the code actually works. 👍

 

And a nice fact, there is only 1 timer active at the same time in the whole resource. That is the whole purpose of the second Lua file timer_c.Lua = Timer lag reduction.

Edited by IIYAMA
Link to comment
On 09/05/2020 at 13:22, IIYAMA said:

I am not sure, I don't have anybody that I can test it with. For hardware that can run basic GTA properly, it should be fine.

If anybody that has an old computer, I would be very happy if that person could make a benchmark.

The CPU usage was normal (average 0.62% in IPB when flying around the map) on my Intel Celeron E3200 (2.40 GHz)

This PC only have a integrated video card with 128 MB dedicated video memory, so the only problem is the lower fps because a lot of objects drawed. (Tested on a green venturas map with the forest generator publiced by Essle ~ Total 2124 tree objects created)

But yeah, this is a great work :)

 

  • Like 2
Link to comment
  • 2 weeks later...
  • 2 weeks later...
  • 2 weeks later...
39 minutes ago, MrKAREEM said:

Make sure that you did not change the file name, or that when you changed it, you did not place spaces in the name

spacer.png

if I’m not mistaken, I haven’t changed anything since the moment I downloaded the script ¯\_(ツ)_/¯

Link to comment
  • Moderators
18 minutes ago, SanMartin said:

if I’m not mistaken, I haven’t changed anything since the moment I downloaded the script

  • The resource has been unpacked, which is already a change. (not required to unpack, except in special cases)
  • The resource name has been changed, since it original is written lowercase.

Which are not really changes that can cause big problems... but you definitely did make changes.


What happens if you use the /refreshall command as administrator?

Check the server window to see if there are any errors and if the resource is available.

 

Link to comment

Thanks more for the comments, all methods have been tried. The result is as follows:

[01:50:10] Not starting resource draw-distance as this server version is too low (1.5.4 required)
[01:50:10] start: Failed to start resource 'draw-distance'

Does this mean that I need to install an older version of the MTA, or is it somehow necessary to update the server?

Sorry for my bad english)

Link to comment
  • Moderators
1 minute ago, SanMartin said:

Thanks more for the comments, all methods have been tried. The result is as follows:

[01:50:10] Not starting resource draw-distance as this server version is too low (1.5.4 required)
[01:50:10] start: Failed to start resource 'draw-distance'

Does this mean that I need to install an older version of the MTA, or is it somehow necessary to update the server?

Sorry for my bad english)

 

I am not sure which version you are using. But the resource might be working fine for your server, if you do the following:

Remove the following line from your meta.xml

<min_mta_version server="???" client="???" />

 

But be aware that you might see some warnings, which are related to functions that are not available inside of your server (version).

  • setPedsLODDistance = available ???
  • setVehiclesLODDistance = available ???

 


 

Updating your server, might be handy if you want to be able to use the resources that use the newest features.

 

 

 

 

 

  • Thanks 1
Link to comment

When I deleted the line, I received an error that indicated to me that there was no line. So I just reinstalled the mta client to a new one. As it turned out, I used the old modified client. Everything works, the script is just perfect.
I don’t understand where you have so much patience to bail out fools like me. Thank)

  • Like 1
Link to comment
  • 10 months later...
On 08/05/2020 at 16:24, IIYAMA said:

 

Distância de traçado v1.0.2

Este recurso melhora a distância de alcance de todos os seus recursos que fazem uso de arquivos de mapa. Isso deixa seus mapas 10x mais bonitos na minha opinião!

spacer.png

  • Melhora muito a distância de alcance dos objetos do mapa
  • Maximização da distância de alcance para pedestres e veículos. (Ver configurações MTA> vídeo: Renderizar veículos sempre com muitos detalhes + Renderizar peds sempre com muitos detalhes)
  • Suporte a vários recursos (este efeito é aplicado em todos os elementos mapRoot)
  • O método de carregamento paralelo é usado, mas a velocidade de carregamento é, nesse caso, reduzida para melhorar o desempenho.
  • O efeito não se aplica apenas aos recursos que estão sendo iniciados , mas também aos recursos que estão em execução .

 

  Baixe aqui  

T h i s r e s o u r c e é uncompiled!

Repositório: https://gitlab.com/IIYAMA12/draw-distance


 

 

Vídeo - Criado por@ Anx1ty

 

 


Comparação

31085.png

Começando a 200 unidades de distância

 

31084.png

400 unidades de distância (esta é a distância onde muitos objetos serão descarregados, mas neste caso trocados com objetos lowLOD)

 

31083.png

E mesmo a 600 unidades de distância, é tecnicamente visível -> (enquanto a névoa está lentamente consumindo tudo ... :eating:)

 

  Baixe aqui  

 

Todo o hardware pode executar isso? -> Não tenho ideia ... provavelmente 😷. Apenas tente.

 

 

please do a tutorial on how to use this script !!

Link to comment
  • Moderators
7 hours ago, gabriel01010 said:

please do a tutorial on how to use this script !!

Is that really necessary? All you have to do is start the script.

 

[v1.0.2] The script will start reading the element tree of running resources and mirror the objects with lowLOD elements. That is all there is to it at the very basic.

Tre.png

 

 

Link to comment
1 hour ago, IIYAMA said:

Isso é mesmo necessário? Tudo que você precisa fazer é iniciar o script.

 

[v1.0.2] O script começará a ler a árvore de elementos de recursos em execução e espelhará os objetos com elementos lowLOD. Isso é tudo o que há para fazer no básico.

Tre.png

 

 

when I'm going to start the following error appears

Not starting the resource distance, as this version of the server is very low 1.5.4

Link to comment
  • Moderators
26 minutes ago, gabriel01010 said:

when I'm going to start the following error appears

Not starting the resource distance, as this version of the server is very low 1.5.4

 

  1. open the file meta.xml
  2. Remove the following line: <min_mta_version client="1.5.4" server="1.5.4" />

The script will start, but some of the new features will not work (like increased draw distance for vehicles and peds). You could notice some errors in the console at the following lines, but that should be fine.

 

 

 

  • Thanks 1
Link to comment
5 hours ago, IIYAMA said:

 

  1. abra o arquivo meta.xml
  2. Remova a seguinte linha: <min_mta_version client="1.5.4" server="1.5.4" />

O script will start, but some of the new features will not work (like increased draw distance for vehicles and peds). You could notice some errors in the console at the following lines, but that should be fine.

 

 

 

Funcionou! obrigado.

  • Like 1
Link to comment
  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...