Jump to content

SetWeaponProperty does not work/SetWeaponProperty не работает


Recommended Posts

SetWeaponProperty does not work help please

 

local cFunc = {}
local cSetting = {}

setWeaponProperty("sawed-off", "pro", "maximum_clip_ammo", 4)
setWeaponProperty("sawed-off", "std", "maximum_clip_ammo", 4)
setWeaponProperty("sawed-off", "poor", "maximum_clip_ammo", 4)

 

Link to post
On 04/04/2020 at 00:24, Haxardous said:

why you're applying 3 different properties at the same time?

You do need to set the property separately for each of the three skill levels, so what he is doing is correct afaik... this being said I don't know why it wouldn't work, I never tried to increase ammo for sawed-off

 

Link to post
On 03/04/2020 at 22:15, Military Guy said:

SetWeaponProperty does not work help please

 

local cFunc = {}
local cSetting = {}

setWeaponProperty("sawed-off", "pro", "maximum_clip_ammo", 4)
setWeaponProperty("sawed-off", "std", "maximum_clip_ammo", 4)
setWeaponProperty("sawed-off", "poor", "maximum_clip_ammo", 4)

 

--serverside

addEventHandler ( "onResourceStart", root, function ( )
        for _,skill in ipairs({"poor","std","pro"}) do  
            setWeaponProperty("sawed-off", skill, "maximum_clip_ammo", 4)
 
        end
    end)

heres a better way

and

please next time read wiki 

Edited by jakson
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...