Sign in to follow this  
Dychuk

Problems with car components

Recommended Posts

Hello! On my server, the components of the car tuning break down (example in the screenshot). This happens after I go to a foreign server. And when I go to my server, there is such a problem. I also noticed that after entering other servers, then my animations do not work. The problem is solved only after restarting the MTA client. But this is not an option. It turns out that the MTA client does not clean client information when a player visits other servers, hence the question: how can I clean this information myself so that players do not restart the client?
engineRestoreModel and resetVehicleComponentPosition did not help

G1lGeiyP6oE.jpg

Share this post


Link to post

The resources are probably named the same as on the other servers, this would cause the data to overlap

Share this post


Link to post
18 minutes ago, Motar2k said:

The resources are probably named the same as on the other servers, this would cause the data to overlap

I also thought that in this case it might be possible, but the resources are in a separate folder. Hence the conclusion is that it is possible to change client data on another servers (maybe not everything data, but some), that is, it is an MTA bug, isn’t it?

Share this post


Link to post

I've had a bug where if I have a vehicle paintjob set on one server and enter another, the one from the first server is still applied. Only fix was to restart client as well.

Btw I don't think it matters if the resources are in a seperate folder or not. If they're named the same then they will overlap with other servers' ones. You can see in MTA San Andreas\mods\deathmatch\resources folder that just the resources get downloaded, not the whole folder they're in.

I renamed all resources at my server by adding a prefix to them. This not only solves such overlap problems but also means that once players download my stuff the first time, they won't have to ever do so again as when they enter other servers the scripts won't get overwritten. :)

Edited by koragg

Share this post


Link to post
17 hours ago, koragg said:

I've had a bug where if I have a vehicle paintjob set on one server and enter another, the one from the first server is still applied. Only fix was to restart client as well.

Btw I don't think it matters if the resources are in a seperate folder or not. If they're named the same then they will overlap with other servers' ones. You can see in MTA San Andreas\mods\deathmatch\resources folder that just the resources get downloaded, not the whole folder they're in.

I renamed all resources at my server by adding a prefix to them. This not only solves such overlap problems but also means that once players download my stuff the first time, they won't have to ever do so again as when they enter other servers the scripts won't get overwritten. :)

I tried. It doesn't work

Share this post


Link to post

You're loading the .DFF file while a car/cars are spawned on the map:D
The .DFF needs to be loaded before the client spawns, or at least spawn the modded vehicle AFTER loading the .DFF file for it.

Edited by JustinMTA

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.