Jump to content

liblua5.1.so.0: cannot open shared object file: No such file or directory


Recommended Posts

I've recently tested my module on Debian 9.11 server (VPS hosting) and got this error:
MODULE: Unable to load mods/deathmatch/modules/ml_base.so  (liblua5.1.so.0: cannot open shared object file: No such file or directory)

I compiled and tested it on Ubuntu (local VM via VirtualBox) and it worked perfectly. Did i miss something in makefile?
My current Makefile.mak: https://pastebin.com/k0Nhi9ya

Link to post
Posted (edited)

Solved. I copied liblua5.1.a library  ( /usr/lib/i386-linux-gnu on my device ) next to the Makefile. Also i added -static -L./ flags before the flag -llua5.1 (Makefile)

Edited by JeViCo
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...