Recommended Posts

Olá! Tudo bem?

 

Eu estou na fase final do desenvolvimento do meu servidor, porém estou com uma dificuldade muito grande a respeito da gamemode. Atualmente o servidor está usando a gamemode "Play" e a gameplay "Freeroam" e é aí que está a minha dificuldade.

 

O servidor é totalmente roleplay, portanto eu precisei remover aqueles respawns de veículos que vem por padrão no mapa e também precisei trocar os respawns após o player morrer.

 

Agora eu preciso fazer com que o servidor pare de iniciar o "Freeroam", então eu gostaria de saber o que devo fazer. Normalmente a gamemode "Play" precisa de um resource para funcionar certinho, né? Nesse caso o "Freeroam" é o padrão (https://imgur.com/a/hh0fhOQ) só que o servidor buga quando eu apenas deleto a linha "<include resource="freeroam" />".

 

Eu preciso de algo mais simples de se fazer para que os players não façam coisas que no roleplay não é permitido e também que o próprio servidor não dê essas opções para os players.

 

Edit: Vi que existe a opção de dar stop no resource, mas isso não resolve o problema em questão. Acontece que eu terei de desativar o Freeroam toda vez que o servidor reiniciar, pois ele está iniciando automaticamente por causa da linha "<include resource="freeroam" />" na gameplay "play".

 

Desde já, muitíssimo grato pela orientação. :)

Edited by Fabelix
Adicionar informação importante

Share this post


Link to post

Quais bugs acontecem quando vc remove o include dele do gamemode?

Share this post


Link to post

Então, eu acho que coloquei uma informação errada ali.

 

Na verdade, o servidor não buga. Quando eu removo a linha da resource na gamemode, o servidor continua com o Freeroam ativado. Como se eu não tivesse alterado nada, entende?

Share this post


Link to post

Poste o meta.xml do resource Play.

Lembre-se de usar o botão <> do fórum para postar o código em XML.

Share this post


Link to post

Desculpe pela demora, eu tinha ficado sem internet durante esse tempo todo.

Bom, eu consegui resolver aqui. Criei um novo arquivo para a gamemode e já consigo iniciar o servidor normalmente, sem o Freeroam. 😊

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.