Skraund

Don't work in 1.5.7

Recommended Posts

After updating 1.5.7, the browser stopped loading the local html file and gives an error of 404. In 1.5.6, everything worked fine. Here is the code:
 

local screenWidth, screenHeight = guiGetScreenSize( )

local window = guiCreateWindow( 0, 0, screenWidth, screenHeight, "Web Browser", false )
local browser = guiCreateBrowser( 0, 28, screenWidth, screenHeight, true, false, false, window )
local theBrowser = guiGetBrowser( browser )

addEventHandler( "onClientBrowserCreated", theBrowser, 
	function( )
		loadBrowserURL( source, "http://mta/webfile/file/html/test.html" )
	end
)

Who knows what could be the problem?

Share this post


Link to post

I assume /webfile/ is a different resource then where the file is loaded from?

(In that case it is important that the webfile has atleast started once and the file has been downloaded before the browser request. Check the client folder for the html file. )

 

If it is not that, then indeed it might be a bug. (They disabled the old local url method after all)

 

 

Share this post


Link to post
1 hour ago, IIYAMA said:

I assume /webfile/ is a different resource then where the file is loaded from?

(In that case it is important that the webfile has atleast started once and the file has been downloaded before the browser request. Check the client folder for the html file. )

 

If it is not that, then indeed it might be a bug. (They disabled the old local url method after all)

 

 

Yes, webfile is another resource.
The file is present in the html folder.
I think this is some kind of bug version 1.5.7, because the server worked well when the client version was 1.5.6, then updated the client to 1.5.7, went to the server and this error appeared. I tried to update the server itself, it did not help.

Share this post


Link to post

Hello again to everyone. Today I installed the latest version of the server for Windows. The client is also the latest version. And still, the local path for browsers does not work. Checked on another system, also does not work. I ask you, dear reader, to try to run the code from the first post in version 1.5.7 and unsubscribe here about the results.

  • Like 1

Share this post


Link to post

Brother, I have the same problem, 1.5.7 cannot play the video in the browser, the privious 1.5.6 version work successfully, in this stage, I don't change anything. all of files, html, video and pictures,scripts, are included in the same resource.

my topic:

 

please help us dear developers of MTASA.

On 04/09/2019 at 00:23, IIYAMA said:

I assume /webfile/ is a different resource then where the file is loaded from?

(In that case it is important that the webfile has atleast started once and the file has been downloaded before the browser request. Check the client folder for the html file. )

 

If it is not that, then indeed it might be a bug. (They disabled the old local url method after all)

 

 

Yeah, It might be a bug of new version.

Share this post


Link to post

Is it a zipped resource?

 

Workaround: unzip the resource

 

Or try latest nightly nightly.mtasa.com / Linux.mtasa.com

Share this post


Link to post
2 minutes ago, qaisjp said:

Is it a zipped resource?

 

Workaround: unzip the resource

 

Or try latest nightly nightly.mtasa.com / Linux.mtasa.com

It's a unzipped resource, thanks a lot, I will try it and return you result, thank you again administrator.

Share this post


Link to post
38 minutes ago, qaisjp said:

Is it a zipped resource?

 

Workaround: unzip the resource

 

Or try latest nightly nightly.mtasa.com / Linux.mtasa.com

Dear administrator, I downloaded the 1.5.7 20190910 version, update the server side and client side, the problem(cannot play video) still have. but when I modify the path of video, the page works well in the chrome.

Edited by 669344682

Share this post


Link to post
5 hours ago, qaisjp said:

Is it a zipped resource?

 

Workaround: unzip the resource

 

Or try latest nightly nightly.mtasa.com / Linux.mtasa.com

The resource is unzipped. Client and server latest version. Anyway, nothing works.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.