Jump to content
  • 0

Patching your 1.01 or 2.00 version of gta_sa.exe


darkdreamingdan

Question

  • MTA Team

Important note: before using this patch, first re-download the latest version of MTA from http://mtasa.com/ and re-install it, as the installer contains a procedure to automatically make your GTA installation compatible (without modifying original game files) that for technical reasons isn't included in the MTA auto-updater, on which many users may rely for years without installing MTA, therefore creating a problem if their GTA installation changes at some point.

So, if you currently have no compatibility or have an unsupported version of GTA (prompting you to come here) or any other similar problem, please first re-install MTA. If  this doesn't help, then proceed with the below instructions.

This topic offers a patcher which will patch the following unsupported versions of Grand Theft Auto: San Andreas:

  • USA 1.01
  • USA 2.00
  • European 1.01
  • European 2.00
  • German 1.00
  • German 1.01
  • German 2.00

This patch does NOT turn your gta_sa.exe into a crack/No-CD, but converts your gta_sa.exe to a 1.00 EU version. Please make necessary backups in case something goes wrong; we are not responsible for damaged or lost files.

I have tested this personally, though please post if you have any problems while using the patcher.

Although you will be reverting back to a fully moddable version of the game, you will also lose improvements contained within 1.01+, so downgrade at your own risk. Remember, you can always upgrade back to 1.01 from this patched version. Should you experience any problems you can always reinstall GTA:SA.

Pick one of the following mirrors to download:

Thanks to Mike for testing and mista.maja for helping me get a German gta_sa.exe, and to nippy401 for letting me get ahold of GTA:SA 2.00 :)

I have added 2.0 support for DE, untested.

Regarding users of the Steam version of GTA: San Andreas

This patch is not compatible with the Steam version of San Andreas, primarily because the .exe is completely different. You don't need to use this patcher for the Steam version, as the procedure to make MTA compatible with it is now included in the installer of recent MTA versions.

So if you have the Steam version, follow these steps:

1) install the Steam version of GTA. If you already have it installed, make sure the game, more specifically the EXE is unmodded, or else MTA may be unable to perform the operation.

2) download the latest version of MTA (make sure of this) from http://mtasa.com/ > "Download" and install it. If MTA was already installed, make sure to re-install it (your files and saved settings won't be lost, MTA will be overwritten only) to ensure the Steam compatibility operation is performed by the installer.

* Make sure to repeat this process every time you re-install your Steam version of GTA, or "verify files" (repair install it) in Steam, or whenever a problem occurs with launching GTA.

 

Last resort

This topic and the patcher was created to help a group of users that happen to have either modded, or upgraded versions of GTA:SA.
MTA San Andreas is designed for, and thus best supported on, the original versions of GTA:SA (US 1.0 and EU 1.0 EXE's) without later GTA updates (1.01 and later) applied to it.. these updates only change the EXE and not other game files, and break MTA compabibility.

So that also means if nothing in this topic works for you, the last resort (actually the method of preference in any case) would be to re-install GTA from DVD so that you will get the original EXE (US or EU 1.0) which MTA supports entirely. As far we know, no DVD version contains an updated EXE (1.01 or later) and they are all 1.0.

If you find a retail version with an updated EXE, this patcher is still likely to work for it, unlike any modded GTA versions (based on 1.01 or later) from shady sources which the patcher may not recognize. So because of the higher success rate for original game in any shape, we recommend you to only get the original game from retail (DVD or digital download) and we tend to only offer support if this is the case. MTA will not provide support for attempts to downgrade/make compatible cracked, or heavily modded installations of GTA. Besides the ethical aspect, MTA is also designed to best support unmodded versions and stability or functioning isn't even guaranteed in other scenario's.

For more information on places where you can buy legitimate and supported versions of GTA, we advise you to visit this wiki page: 

https://wiki.multitheftauto.com/index.php?title=Where_to_buy_GTASA

 

NOTE: There have been numerous cases of people externally linking directly to the file. If you wish to link to the downgrader, I request that you link to this TOPIC, not directly to the file. This is to ensure that users having trouble post in this thread rather than creating new topics. If you would like to mirror it please contact an administrator.

* Topic update date: 29th March 2020

Changelog: 

updated Steam compatibility information
added more information

 

Link to comment
  • Answers 381
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 0

...ok...

I got the downgrader installed, but as soon as I click "New Game", it loads all the way, but once loaded, just a black screen. I DID install a mod (FBI Hummer, gta3.img) before running the first time.

Why me? =\

PS: When loading a game, it works. But the mods don't take effect.

Link to comment
  • 0

ok..i wannna revert to 1.0 from 2.0 im reading here and its the place but i dont see a frickin patch here? whats the deal? anyone know where i can get the patch..the links below only installed mta..and that dont work on 2.0, im very frustrated at this point. :?

Link to comment
  • 0
ok..i wannna revert to 1.0 from 2.0 im reading here and its the place but i dont see a frickin patch here? whats the deal? anyone know where i can get the patch..the links below only installed mta..and that dont work on 2.0, im very frustrated at this point. :?

The link is on the first page of this thread, there are three mirrors for it.

this forum is backward..oldest posts show first and new posts are on page 15. wth?not that anyone will ever read this, because its on page 15.

Uh, all forums are like this. It would be pretty hard to follow a discussion reading posts in reverse order.

Link to comment
  • 0

ok let me get this straight.

I'm gonna buy GTA San Andreas from BestBuy tomorrow. I really want to play MTA. but the version of the game is definetely gonna be 2.0. I have no idea how to edit files and all that other stuff. I just want to know that once dl the patch and dl MTA. What are the chances that i will be able to play MTa.

P.S. will I still be able to use car mods and weapon mods without it reverting back to 2.0?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...