Jump to content

Fazer output para server race


Recommended Posts

  • Other Languages Moderators
local message = "Seja bem-vindo ao servidor MrShadows Race.";

addEventHandler( "onResourceStart", root, function( res )
	local res_type = getResourceInfo( res, "type" );
	
	if ( res_type and res_type == "map" ) then
		outputChatBox( message, root, 255, 255, 255, true );
	end
end );

Server-side.

  • Confused 1
Link to comment
On 26/04/2019 at 22:28, #DeltaSCR said:

@MrShadows NÃO REVIVA TÓPICOS ANTIGOS! 

Ah, desculpe, sou novo no forum.

On 26/04/2019 at 22:57, DNL291 said:

O post foi separado do primeiro tópico para um tópico novo. @MrShadows  Evite reviver os antigos, e nesse caso o tópico revivido nem tinha nada a ver com o seu post.

Desculpe, pois não sabia como criar um topico novo, sou novo no forum.

On 26/04/2019 at 23:32, Renazz said:
local joinMessage = "Seja bem vindo ao !MrShadows race"

se ajudei por gentileza pode avaliar minha resposta

Eu colo em qual pasta?

Link to comment
On 03/05/2019 at 22:09, DNL291 said:

Cria um arquivo .lua e cola esse código, faz o meta.xml (clique no link e leia) dele e deixa os 2 arquivos numa pasta; a pasta você deixa no diretório [...]server\mods\deathmatch\resources

Aqui um link útil pra você ler:

https://wiki.multitheftauto.com/wiki/PT-BR/Introdução_ao_Scripting

Criei o arquivo.lua e na meta coloquei assim 

<meta>
    <info author="MrShadows" type="script" name="Race MrShadows" />
    <script src="mensagem.lua" type="server" />
</meta>

No arquivo.lua colei o script mandado mas ainda assim não apareceu nada ...

Link to comment
  • Moderators

Você tem permissão de admin no server? Digite o comando /debugscript 3 no jogo e dê start no resource. Pode ser também que o resource não foi incluído na lista pois não foi atualizado com o comando refresh ou algum erro no código.

Link to comment
14 hours ago, DNL291 said:

Você tem permissão de admin no server? Digite o comando /debugscript 3 no jogo e dê start no resource. Pode ser também que o resource não foi incluído na lista pois não foi atualizado com o comando refresh ou algum erro no código.

Eu tenho permissão de admin e ja fiz o comando /debugscript 3 e dei start no resource e ele ja esta na lista de resources mas ainda nao apareceu nada

Link to comment
  • Moderators

Digita no Console o comando /info nome_do_resource Se o status tiver ok, tente isto e veja no jogo se mostra alguma mensagem no chat ao ligar:

local message = "Seja bem-vindo ao servidor MrShadows Race.";

addEventHandler( "onResourceStart", root, function( res )
	local res_type = getResourceInfo( res, "type" );
    outputChatBox("Resource Iniciado!")
	
	if ( res_type and res_type == "map" ) then
		outputChatBox( message, root, 255, 255, 255, true );
	end
end );

 

  • Thanks 1
Link to comment
1 hour ago, DNL291 said:

Digita no Console o comando /info nome_do_resource Se o status tiver ok, tente isto e veja no jogo se mostra alguma mensagem no chat ao ligar:

local message = "Seja bem-vindo ao servidor MrShadows Race.";

addEventHandler( "onResourceStart", root, function( res )
	local res_type = getResourceInfo( res, "type" );
    outputChatBox("Resource Iniciado!")
	
	if ( res_type and res_type == "map" ) then
		outputChatBox( message, root, 255, 255, 255, true );
	end
end );


 

Ainda não aparece e quando clico pra iniciar ele executa outro chatbox "Para ativar/desativar a música pressione m"

e no status aparece sempre escrito: parado 

e tambem aparece isso no console quando inicio o script 

SCRIPT ERROR: mensagem1\script.lua:11: unexpected symbol near '?' (um simbolo de interrogação) 

Este aqui até funcionou mas meu player spawna em outro local ...

local spawnX, spawnY, spawnZ = 1959.55, -1714.46, 10
function joinHandler()
	spawnPlayer(source, spawnX, spawnY, spawnZ)
	fadeCamera(source, true)
	setCameraTarget(source, source)
	outputChatBox("Bem-vindo ao meu servidor!", source)
end
addEventHandler("onPlayerJoin", getRootElement(), joinHandler)
Edited by MrShadows
Estava faltando algo
Link to comment
1 hour ago, MrShadows said:

Ainda não aparece e quando clico pra iniciar ele executa outro chatbox "Para ativar/desativar a música pressione m"

e no status aparece sempre escrito: parado 

e tambem aparece isso no console quando inicio o script 

SCRIPT ERROR: mensagem1\script.lua:11: unexpected symbol near '?' (um simbolo de interrogação) 

Este aqui até funcionou mas meu player spawna em outro local ...

local spawnX, spawnY, spawnZ = 1959.55, -1714.46, 10
function joinHandler()
	spawnPlayer(source, spawnX, spawnY, spawnZ)
	fadeCamera(source, true)
	setCameraTarget(source, source)
	outputChatBox("Bem-vindo ao meu servidor!", source)
end
addEventHandler("onPlayerJoin", getRootElement(), joinHandler)

 

1 hour ago, MrShadows said:

Ainda não aparece e quando clico pra iniciar ele executa outro chatbox "Para ativar/desativar a música pressione m"

e no status aparece sempre escrito: parado 

e tambem aparece isso no console quando inicio o script 

SCRIPT ERROR: mensagem1\script.lua:11: unexpected symbol near '?' (um simbolo de interrogação) 

Este aqui até funcionou mas meu player spawna em outro local ...

local spawnX, spawnY, spawnZ = 1959.55, -1714.46, 10
function joinHandler()
	spawnPlayer(source, spawnX, spawnY, spawnZ)
	fadeCamera(source, true)
	setCameraTarget(source, source)
	outputChatBox("Bem-vindo ao meu servidor!", source)
end
addEventHandler("onPlayerJoin", getRootElement(), joinHandler)

Resolvi o problema, eram só algumas linhas a mais no script deletei-as e agora funcionou tudo ok porem quero a mensagem só apareça quando o jogador se conectar e não quando estiver mudando de mapa poderia me ajudar?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...