Z4Zy

Return Running Resources On MTA Server

Recommended Posts

Hello !

          Actually the problem is, I had to restart the server. And there are number of resources running on the server now. After restarting the server, I had to start them one by one to come into the previous position :shock: Are there any scripting solution [ or another method ] that I can obtain as a solution in this occasion ?

Share this post


Link to post

What exacly happend the resource is not runing? 

Share this post


Link to post
6 hours ago, Dimos7 said:

What exacly happend the resource is not runing? 

Nothing !

I mean to save the time that had to spend when searching and starting the stopped resource when restarting the server.

Share this post


Link to post

mtaserver.conf

At the end of the file

<resource src="admin" startup="1" protected="0" />
    <resource src="defaultstats" startup="1" protected="0" />
    <resource src="helpmanager" startup="1" protected="0" />
    <resource src="joinquit" startup="1" protected="0" />
    <resource src="mapcycler" startup="1" protected="0" />
    <resource src="mapmanager" startup="1" protected="0" />
    <resource src="parachute" startup="1" protected="0" />
    <resource src="performancebrowser" startup="1" protected="0" />
    <resource src="reload" startup="1" protected="0" />
    <resource src="resourcebrowser" startup="1" protected="1" default="true" />
    <resource src="resourcemanager" startup="1" protected="1" />
    <resource src="scoreboard" startup="1" protected="0" />

....

 

  • Like 2

Share this post


Link to post
19 hours ago, Overkillz said:

mtaserver.conf

At the end of the file


<resource src="admin" startup="1" protected="0" />
    <resource src="defaultstats" startup="1" protected="0" />
    <resource src="helpmanager" startup="1" protected="0" />
    <resource src="joinquit" startup="1" protected="0" />
    <resource src="mapcycler" startup="1" protected="0" />
    <resource src="mapmanager" startup="1" protected="0" />
    <resource src="parachute" startup="1" protected="0" />
    <resource src="performancebrowser" startup="1" protected="0" />
    <resource src="reload" startup="1" protected="0" />
    <resource src="resourcebrowser" startup="1" protected="1" default="true" />
    <resource src="resourcemanager" startup="1" protected="1" />
    <resource src="scoreboard" startup="1" protected="0" />

....

 

exactly that is ! But the problem is I want to get the resource names currently running on the server to add there...

Share this post


Link to post

Yes you can. You must probally use onResourceStart, getResourceName.

Store the name of the resources (to start them by your code) in a list and add THAT RESOURCE you have to add on the previous list mentioned.

Share this post


Link to post
1 hour ago, DeadthStrock said:

exactly that is ! But the problem is I want to get the resource names currently running on the server to add there...

You can't add them there automatic. But there are two other ways to start resources.

 

0.

 

Ways of starting:

 

  1. https://wiki.multitheftauto.com/wiki/StartResource  https://wiki.multitheftauto.com/wiki/RestartResource (requires admin rights)
  2. <include /> https://wiki.multitheftauto.com/wiki/Meta.xml (warning: the source resource can't be started if the included resources are missing or broken, this can be annoying or a benefit for validation)

 

 

 

 

 

 

Edited by IIYAMA
  • Like 1
  • Thanks 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.