DeadthStrock

Immortal Peds 0_0

Recommended Posts

Hello !

    I have a probblem. Everytime when I creating a ped in the server using 'createPed' function, the ped that creating can't be killed [ immortal ]. I don't like that way. The ped should be able to killed. Did you know to fix this ?

createPed(0, 0, 0, 5)

 

Edited by DeadthStrock
  • Like 1

Share this post


Link to post

There's no such argument as 'immortal' in createPed.

ped createPed ( int modelid, float x, float y, float z [, float rot = 0.0, bool synced = true ] )

It must be something else in your code which is making your ped invincible. Or it could be this issue, https://bugs.mtasa.com/view.php?id=8790.

Share this post


Link to post
56 minutes ago, DeadthStrock said:

Hello !

    I have a probblem. Everytime when I creating a ped in the server using 'createPed' function, the ped that creating can't be killed [ immortal ]. I don't like that way. The ped should be able to killed. Did you know to fix this ?


createPed(0, 0, 0, 5)

 

Can all peds not get killed?

If that is the case, then this event is cancelled in one of your resources:

https://wiki.multitheftauto.com/wiki/OnClientPedDamage

 

 

 

Share this post


Link to post
13 hours ago, IIYAMA said:

Can all peds not get killed?

If that is the case, then this event is cancelled in one of your resources:

https://wiki.multitheftauto.com/wiki/OnClientPedDamage

 

 

 

I stopped my modified resources and then started the local server with built-in resources. If I create 10 peds, I can't even kill a single ped with a gun. [ knife will do :P stealth kill I think ]

--------------------------------------------------------------------------------------------------------------------------------------------------------------

14 hours ago, Bilal135 said:

There's no such argument as 'immortal' in createPed.


ped createPed ( int modelid, float x, float y, float z [, float rot = 0.0, bool synced = true ] )

It must be something else in your code which is making your ped invincible. Or it could be this issue, https://bugs.mtasa.com/view.php?id=8790.

I saw that bug. But I don't try to set health of any ped. Their health doesn't change after spawn. I tried this with built-in resources of MTA local server.

Share this post


Link to post
55 minutes ago, DeadthStrock said:

I stopped my modified resources and then started the local server with built-in resources. If I create 10 peds, I can't even kill a single ped with a gun. [ knife will do :P stealth kill I think ]

--------------------------------------------------------------------------------------------------------------------------------------------------------------

I saw that bug. But I don't try to set health of any ped. Their health doesn't change after spawn. I tried this with built-in resources of MTA local server.

What about other players in the same server?

What about you killing peds inside of a server that isn't yours?

Did you modifi any mods or textures?

Ask these kind of questions to yourself.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.