Dutchman101

Known issues with input lag/heavy FPS stutter

qaisjp

THIS HAS NOW BEEN FIXED IN LATEST BUILD

Available NOW! at https://www.multitheftauto.com

Message added by qaisjp

Recommended Posts

If you are still experiencing problems, follow the instructions:

 


 

Hi,

We are aware of the recent issues with heavy game lag (tied to mouse input) which is a problem independent of the MTA build revision for reasons known to us. Because knowing where it is related to doesn't mean we can pinpoint the exact cause immediately, please bear with us while we try to resolve this high-priority problem; we understand that while not everyone is affected, it can make the game near-impossible to play for those affected.

In the meanwhile, you can try a work-around that has proven to be a temporary fix for those eager to play despite the issues: set MTA to Windowed mode (settings > video > Fullscreen mode). We realize that this looks ugly and for sure isn't a proper fix, but it may help you on the short-term.

Please understand that resolving these issues is our top-priority at the moment.

 

Note: this thread should serve for data collection and sharing possible temporary solutions with your fellow MTA players. Tens of users have raised a support case with us either on the Client support section or Discord in the past week, please continue to post about your situation in this topic, it may prove to be helpful for us to pinpoint and fix the underlying problem quicker than we would otherwise be able to. For the same reasons, any functional work-around can also provide us more insights.

You can help by linking anyone experiencing the mentioned issues to this topic, and posting the link in any separate client support topic made about it. Also, the most voiced workarounds (which we know of from earlier reports on the issue) that however, do not work out for everyone, are;

- running MTA 'as Administrator' (right-click) and/or setting compatibility mode to earlier Windows versions such as Windows 7

  • Like 4
  • Sad 1

Share this post


Link to post

Hey!

I just want to point out a few things for those who will try and fix the bug

  1. Re-installing MTA will not work
  2. Re-installing GTASa will not work
  3. Deleting stuff from MTA folder will not work
  4. Deleting stuff from GTASa folder will not work
  5. Playing around with any other option except Windowed mode located in Options > Video > Next to screen resolution will not work
  6. Playing around with the options of GTASa will not affect MTA

In conclusion:

Wait for a new patch for the fix and play on windowed mode if you are really in need of playing 

Share this post


Link to post

No need to take the window mode.

I have been talking about this situation in a couple of my players but I have not been able to propose a solution because I have not faced this problem.
They found a solution.

Right click on the MTA to fix the compatibility issue and click on Start as administrator and the problem is solved.

Share this post


Link to post
Just now, Query said:

No need to take the window mode.

I have been talking about this situation in a couple of my players but I have not been able to propose a solution because I have not faced this problem.
They found a solution.

Right click on the MTA to fix the compatibility issue and click on Start as administrator and the problem is solved.

Unfortunately I've tried running MTA with administrator rights but it did not work for me sadly

  • Like 1

Share this post


Link to post

Mark compatibility at the bottom.

As in the picture; unknown.png

 

and  Click on Start as administrator and apply.

Share this post


Link to post
5 minutes ago, Query said:

Mark compatibility at the bottom.

As in the picture; unknown.png

 

and  Click on Start as administrator and apply.

Doesnt work, checked compatibilty option, checked start as administrator and applied, got into the menu and heavy mouse lag again, I get off the game go back to the options to check if everything is correct and the compatibility mark has been removed, dunno what that has to do

  • Like 1

Share this post


Link to post

Interesting, can you make a "dxdiag" image? I will forward it to MTA-Team.

Except that one; Many of my gamers have solved this problem by doing the way I told you.
 

Share this post


Link to post
2 minutes ago, TheBigSad said:

What would a "dxdiag" image mean, a full imgur list of my dxdiag?

windows > execute > DxDiag.exe

Share this post


Link to post
14 minutes ago, Query said:

Yes, full dxdiag image.
I will forward it to the MTA team.
 

Just for clarity, we don't need people to collect logs from others to foward them to us. We will use this topic for data collection ourselves.

4 minutes ago, TheBigSad said:

How do I forward the text file towards the MTA team

If you want to help out in such a way, then please don't generate a DxDiag log but use MTADiaghttps://forum.mtasa.com/topic/32071-mtadiag-diagnostic-tool-for-mtasa/

You can simply reply with the link to your log

 

Share this post


Link to post
4 minutes ago, Dutchman101 said:

Just for clarity, we don't need people to collect logs from others to foward them to us. We will use this topic for data collection ourselves.

If you want to help out in such a way, then please don't generate a DxDiag log but use MTADiaghttps://forum.mtasa.com/topic/32071-mtadiag-diagnostic-tool-for-mtasa/

You can simply reply with the link to your log

 

https://pastebin.mtasa.com/218975438

Share this post


Link to post

انا عرفت بان وقت اطلع ل قائمة الويندوز الفي بي اس يعلى بلعبة بس وقت ارجع ادخل العبة يرد ينخفض للاسف و هذه المشكلة تواجه بعض لاعبين و منهم اصدقائي رغم ان اجهزتنا قوية للغاية

  • Like 1

Share this post


Link to post

i also have the same problem      " my GPU   nvidia gt630 "                    8gb ram                     CPU "i3 3240"

Share this post


Link to post

Luckily not affected by the FPS issue, but some players on our server are. Dutchman101 i wish you and the MTA team all the best finding and resolving this matter.

Share this post


Link to post

Is this that problem when you set bigger FarClipDistance and look down, and you lag and the player becomes invisible, and cant see the ground?

Share this post


Link to post
2 minutes ago, Foolkep said:

Is this that problem when you set bigger FarClipDistance and look down, and you lag and the player becomes invisible, and cant see the ground?

Nnnnnn-not aware of that mate, this bug is basicly you are just playing MTA and all of the sudden your MTA crashes, you boot it up once again and you begin your journey to play MTA with 3-6 FPS and even 0-1 when you are moving your mouse

Edited by TheBigSad

Share this post


Link to post

no when i move my mouse my fps drops to 3 or 10  BUT when im not moving my mouse my fps goes normal

Share this post


Link to post

Well, we have to wait. Thanks you for your help, I really appreciate it

Share this post


Link to post

hi ..
i was just having an anoyying trouble all day which 've actually annoyed me so bad ..and the problem is there is a terrrrrrible mouse lag which is present only in mta which made it really impossible to play but it disappears when i go to windowed and reduce my resolution

plz any of the admins or anybody who knows the solution answer me what should i do

and here is my pastebin thing
https://pastebin.mtasa.com/495711278

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.