Sign in to follow this  
AliGerami

Unknown exception thrown

Recommended Posts

Hi, I'm getting a crash as soon as I want to enter my local server using latest repo and only RELEASE build. (Didn't try with Nightly build)

I'm not getting any crashes while entering the server on Debug build (I mean, client debug build, server is fine), and here's the info:

Version = 1.5.5-custom.0.000
Time = Wed Feb 28 04:28:08 2018
Module = D:\MTASAClone\mtasa-blue\Bin\mta\multiplayer_sa.dll
Code = 0xC0000005
Offset = 0x0000495E

EAX=79616C70  EBX=00000000  ECX=00B6F028  EDX=0FA80000  ESI=03D65ED8
EDI=00000000  EBP=742ADEE0  ESP=0177FD70  EIP=771F495E  FLG=00010202
CS=0023   DS=002B  SS=002B  ES=002B   FS=0053  GS=002B

And when I debugged into it, here's what I got:

qmYBlk.png

(Dump file: https://dl.dropboxusercontent.com/s/vox4gygmapndqsr/client_1.5.5-custom.0.000_multiplayersa_0000495e_5_DMMB_0100007F_55F3_004_D7767_20180228_0428.dmp)

I haven't crashes on the latest stable build (1.5.5), haven't tried nightly build and I DON'T THINK those recent commits caused this, also I'm having the same crash on my other PC.

Any ideas?

Edited by AliGerami

Share this post


Link to post

This is probably a symptom of heap corruption. Debug mode works fine for me too, I get the same error when I compile in release, so it's not just you.

Version = 1.5.5-custom.0.000
Time = Wed Feb 28 07:09:52 2018
Module = C:\Users\danish\Documents\Git\Github\Repositories\saml1er\mtasa-blue\Bin\mta\multiplayer_sa.dll
Code = 0xC0000005
Offset = 0x0000498E

EAX=79616C70  EBX=00000000  ECX=00B6F028  EDX=0FD90000  ESI=03C627D0
EDI=00000000  EBP=76C7DEE0  ESP=0177FD70  EIP=0F14498E  FLG=00010202
CS=0023   DS=002B  SS=002B  ES=002B   FS=0053  GS=002B

 

Share this post


Link to post

You have to disable function inline'ing for Game SA and Multiplayer SA in Release config due to a compiler bug. You can find the setting under Project settings > C/C++ > Optimization > Inline Function Expansion, set it to Disabled (/Ob0) (https://msdn.microsoft.com/en-us/library/47238hez.aspx) and recompile.

  • Thanks 1

Share this post


Link to post
23 minutes ago, Necktrox said:

You have to disable function inline'ing for Game SA and Multiplayer SA in Release config due to a compiler bug. You can find the setting under Project settings > C/C++ > Optimization > Inline Function Expansion, set it to Disabled (/Ob0) (https://msdn.microsoft.com/en-us/library/47238hez.aspx) and recompile.

Yeah, it solved the problem.

I think you should turn optimization off from premake (Client\game_sa\premake5.lua & Client\multiplayer_sa\premake5.lua) so there will be no more issues like this.

optimize "Off"

Now encountering process stuck xD

Edited by AliGerami

Share this post


Link to post
2 hours ago, AliGerami said:

Now encountering process stuck xD

ftTmET.png

@Necktrox What about this one?

Edit: Tried turning off optimization for Client Deathmatch but, the same exception has thrown.

Edited by AliGerami

Share this post


Link to post

I'm encountering same issue even with inline optimizations disabled
GoUNBa5.png

  • Sad 1

Share this post


Link to post

@quindo you might have not disabled them properly then. Check the configuration type at top left when you click on properties, and make sure "Release" is selected. Also, after fixing your settings, execute "win-install-data.bat" to move netc.dll there.

Share this post


Link to post

You can alternatively update to the latest VS2017 version (15.6) which contains the bugfix.

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.