danylopez123

Cant change gamemode: gamemode resource could not be started

Recommended Posts

When i try to change from "play" to another gamemode like "race", i get this problem:

[2017-10-06 03:04:03] Stopping play
[2017-10-06 03:04:03] Stopping freeroam
[2017-10-06 03:04:04] startResource: Failed to start resource 'race'
[2017-10-06 03:04:04] ERROR: mapmanager\mapmanager_main.lua:376: mapmanager: gamemode resource could not be started.

Share this post


Link to post

Your code in race resource might have errors. Have you modified anything since last successful start?

Share this post


Link to post

Check gameplay folder try to reinstall new MTA folder it works ,if you done any editing then go to map manger.lua376 fix those errors 

Share this post


Link to post

Saml1er: No, i didint edited anithing because i dont know what to edit for race

Khadeer143: Are you telling me to install MTA on a new folder, then copy everithing from resources to my origial MTA folder?

Besides, what i see on the line 376 is this:

function startGamemodeT(gamemode)
    setTimer(startGamemode, 50, 1, gamemode)
end

Edited by danylopez123
Included the line 376

Share this post


Link to post

I tried to install MTA on a new folder and then overwrite every resource from my original one, it didint worked, same error, and again, i didint edited anything

Share this post


Link to post

It must work ,when u install new MTA folders ,or resource folder!u may have local server files in ur PC right? Check on ur local MTA sa if it works there then upload those  local resource folder by deleting ur host resource folder and start again by  stop play ,even why u stopping play ,free roam u can simply start from console ,f8 ,by start the map name it will stop play and free roam when  u done with race mode then do start play it again start free roam !

6 hours ago, MIKI785 said:

Get the latest resources here: http://mirror.mtasa.com/mtasa/resources/mtasa-resources-latest.zip and just copy them into your resources (especially mapmanager and race).

Its not about latest files ,he missed some files of map manager by uploading new resources foleder it will fix 

Edited by Khadeer143

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.