Search the Community

Showing results for tags 'problemas'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Multi Theft Auto: San Andreas 1.x
    • Support for MTA:SA 1.x
    • User Guides
    • Open Source Contributors
    • Suggestions
    • Ban appeals
  • General MTA
    • News
    • Media
    • Site/Forum/Discord/Mantis/Wiki related
    • MTA Chat
    • Other languages
  • MTA Community
    • Scripting
    • Maps
    • Resources
    • Other Creations & GTA modding
    • Competitive gameplay
    • Servers
  • Other
  • Archive
  • Private Bugtracker

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Gang


Location


Occupation


Interests

Found 2 results

  1. Eu estava fazendo um trabalho de pedreiro que consistia em pegar o emprego, ir ao prédio em construção, pegar a viga e entregar ao pedreiro. queria por um sistema de progresso de 0 a 100%. Alguem pode me ajudar? https://prnt.sc/q7idt6 imagem de exemplo
  2. Opa, estou começando a mexer com sqlite e no momento estou tentando fazer um simples registro por comando... porém não consigo segue abaixo o codigo: local connect = dbConnect("sqlite", "registry.db") addEventHandler("onResourceStart", resourceRoot, function() local exec = executeSQLQuery("CREATE TABLE IF NOT EXISTS registroPessoal (ID INTEGER NOT NULL PRIMARY KEY, username TEXT, password TEXT, mtaserial INTEGER, PosX REAL, PosY REAL, PosZ REAL, accountName TEXT)" ) local query = dbQuery( connect, "SELECT * FROM registroPessoal") outputChatBox(tostring(query)) local resultado, searchs, msg = dbPoll(query, 0) if resultado == false then outputConsole( "dbPoll falhou. Erro srch: " .. tostring(searchs) .. " Erro msg: " .. tostring(msg) ) end end) addCommandHandler ("registrar", function(jog, cmd, val1, val2) local valor = dbQuery ( connect , "SELECT username, mtaserial FROM registroPessoal" ) outputDebugString("02") local resultado = dbPoll ( valor ,-1 ) outputDebugString("03") if resultado then outputDebugString("04") for _, search in ipairs ( resultado ) do outputDebugString("05") if (search["username"]) == val1 or search["mtaserial"] == serial then outputDebugString("07") outputChatBox("Esse nome de usuário já existe ou você já possui uma conta! tente novamente", jog) else outputDebugString("08") local serial = getPlayerSerial(jog) local password = tostring(val2) local nmAccount = getAccountName(getPlayerAccount(jog)) local PosX, PosY, PosZ = getElementPosition(jog) executeSQLQuery( "INSERT INTO registroPessoal (username, password, mtaserial, PosX, PosY, PosZ, accountName) valorS(?,?,?,?,?,?,?)", val1, password, serial, PosX, PosY, PosZ, nmAccount ) outputChatBox("Registro bem sucedido!", jog) end end end end) addCommandHandler("deltable", function() executeSQLQuery("DROP TABLE registroPessoal") outputDebugString("table deletada") end ) Fiz a debugação e a função de registrar para antes do for _, search, no caso no outPutDebugString("04"), a partir disto não se lê mais nada, então o problema deve se encontrar no dbPoll... Porém como não tenho muito conhecimento não sei oq esta sendo feito de errado...