TorNix~|nR

Members
  • Content Count

    477
  • Joined

  • Last visited

Everything posted by TorNix~|nR

  1. It's working, thank you so much
  2. I'm using exports of topbar (the script) exports.topbar:dm ( "Use #ff0000/changepw#ffffff to change your account password.", root, 0, 245, 82, true )
  3. Hello guys, I have a little problem that I want to solve I'm using topbar script with showing texts on the console I want to remove the hex colors like #ff0000, but I couldn't do it --[[ Display a DX topbar message ]]-- function dm(text, r,g,b, col, bell) -- Insert message local tick = getTickCount() if text == last_msg then return end if not col then col = false end if bell then playSoundFrontEnd(11) end table.insert(messages, {text, true, tick + display_time_ms, 170, r,g,b, col }) outputConsole("[TOPBAR] "..text) --this is the one last_msg = text setTimer(function() last_msg = "" end, 10000, 1) -- Play a message notification sound --playSoundFrontEnd(11) please any help?
  4. Thank you so much!
  5. TorNix~|nR

    elementType

    Hello guys, I wanted to ask where is the problem in this? I'm getting debug expected argument... how can I fix it? local veh = (getElementType(source) == "vehicle") if veh and isVehicleDamageProof(veh) == false then help please!
  6. hello guys, please I'm wondering why isn't this working for index,thisPlayer in pairs(getElementsByType("player") or getElementsByType("ped")) do nothing found on debug, but only ped works but player not help please?
  7. TorNix~|nR

    Map

    I know, I want to remove it completely, how?
  8. TorNix~|nR

    Map

    Hello guys, please is there anyway to remove these texts from the map (F11) ?
  9. hello guys, I'm wondering how to change the killmessages position from right to left I changed all aligns on gui.lua, but it didn't work any help please?
  10. Hello guys, please I need help I want to allow using the Combat Shotgun ID: 27 to jetpack like other weapons like Pistol, UZI.. etc help please
  11. I'm sorry I didn't see the reply, even the problem is still on xd :( I tested this code on local and it's working, but when I test it on my server it won't work, only the engine, help please addEvent("engenieSwitch", true) addEventHandler("engenieSwitch", root, function(id) local vehicle = getVehicleByID(id) if isElement(vehicle) then if (getVehicleEngineState (vehicle) == true) then setVehicleEngineState (vehicle, false) setVehicleOverrideLights(vehicle, 1) elseif (getVehicleEngineState (vehicle) == false) then setVehicleEngineState (vehicle, true) setVehicleOverrideLights(vehicle, 2) else end end end)
  12. Thank you it's working, but when I open the panel, every 50 milliseconds the ped automatically disappear, this is the problem you can see the image, it appears and suddenly disappears every time I open the panel Code: local x, y, z = getCameraMatrix() local sx, sy = guiGetSize(GUIEditor.staticimage[1], false) local skin = createPed(getElementModel(localPlayer), x, y, z) local view = exports.object_preview:createObjectPreview(skin, 0, 0, 200, 0, 0, sx, sy, false, false, true) setTimer(function ( ) exports.object_preview:saveRTToFile(view, "gui_skin.png") guiStaticImageLoadImage(GUIEditor.staticimage[1], "gui_skin.png") exports.object_preview:destroyObjectPreview(view) destroyElement(skin) end, 50, 1) Image:
  13. is it that hard? any help please?
  14. I used this resource ( object_preview ), the ped is showed but when I save it on png, it saves but saves empty this is the resource on community https://community.multitheftauto.com/index.php?p=resources&s=details&id=11836 any help please? this is the code local x, y, z = getCameraMatrix() local sx, sy = guiGetSize(GUIEditor.staticimage[1], false) local skin = createPed(getElementModel(localPlayer), x, y, z) local view = exports.object_preview:createObjectPreview(skin, 0, 0, 200, 0, 0, sx, sy, false, false, true) exports.object_preview:saveRTToFile(view, "gui_skin.png") exports.object_preview:destroyObjectPreview(view) destroyElement(skin) guiStaticImageLoadImage(GUIEditor.staticimage[1], "gui_skin.png")
  15. @MandaBraza, thank you so much, it's working ^^
  16. anyone help me please?
  17. it's already like that, any other help please?
  18. yes, dxscoreboard but I edit it a little bit
  19. TorNix~|nR

    Scoreboard

    Hello guys, I have weird problem on the scoreboard, the names and teams.. etc doesn't show normally I don't know why? is there any way to fix it
  20. TorNix~|nR

    (AC #4 DHOS)

    Hello guys, I started MTA now, when I enter to any server, I get kicked by this reason, .. was kicked from the game by (AC #4 DHOS) any solution please?, some days ago, it was working without problem Problem solved guys! I restarted the pc and it's fine PS: I never used a hack on mta :3 even I don't know how (I have a server and I do know that meaning xd)
  21. TorNix~|nR

    Mutep

    Guys, please I need help, I just want to show the ..reason.. on the logs, it shows only ..reason.. not the real reason it's not a problem on the script, I added the logs