Jump to content

Xabache

Members
  • Content Count

    134
  • Joined

  • Last visited

Everything posted by Xabache

  1. function testf3() setElementModel(getLocalPlayer(),3183) end nu = 3183 engineImportTXD(engineLoadTXD("0-WhiteDealerForTestingOnlyDeleteLater.txd",nu),nu) engineReplaceModel(engineLoadDFF("0-WhiteDealerForTestingOnlyDeleteLater.dff",nu),nu) When i set this to skin model 1 it works fine. When it set it to the new skin models, it does nothing.
  2. Xabache

    setMoonSize(0)

    @Dutchman101 The moon was being removed by a bug, now fixed, leaving the moon, now removed by a shader, you just wrote. Thank you, it works perfectly. However, setSunSize(0) removes the Sun's disk, if not the godray, and sunlight direction. Which is nice! but.. setMoonSize(0) will never remove the Moon's disk? This seems inconsistent with both the previous sun function, and the meaning of 0 itself. I have setCloudsEnabled(false), but the stars, and Venus the big bright star, still exist. Could you create a shader or function to remove them also? And someday, setStarSize
  3. Xabache

    setMoonSize(0)

    https://upload.mtasa.com/u/631516260/timecyc.dat_ dated 01/07/2005 likely stock
  4. Xabache

    setMoonSize(0)

    @yasin0Placing the above in my meta file, at the top, just above the client and/or server Lua file that contains set moon, this does not fix this in a fresh test server. @King12 Thanks for confirming you have this too! It has been many years since I wrote my live server from modified mta community assets leaving me to ask... @ccwHow would I check if I am using a custom timecyc.dat ? But I can say, I had not modified my server in several years. There had never been moon or stars in that time. From my in game screenshots I can verify that prior to June 26, 2019 there were n
  5. Xabache

    setMoonSize(0)

    For years I enjoyed a moon and star free server. For years I made no changes to my server. Why do I now have a moon? setMoonSize(0) The above, in the past two months or so, now does nothing.
  6. What happened to tow trucks. They use to be one of the funnest vehicles in the game. You could tow away an occupied car... no more. You could create a massive train of tow trucks towing other tow trucks that were towing yet more tow trucks... No more.. Why did this change? Now a tow truck can't tow an occupied car, and it cannot tow a vehicle while being itself towed. This isn't a feature. This is a bug. Please bring back our much loved tow truck, or introduce a switch that allows for old and new tow truck towing policy to be selected by the server owner. Default: Old.
  7. It appears this problem is being caused by the massive 'bad referrers' list. Can't say why. Removing it reduced the bad bots file by 85% and MTA server no longer crashes.
  8. Sorry for the delay. I rebuilt the VPS on CentOS 7.5 x64 and Apache/2.4.6, and in doing so recognized that I was not running them stock as I assumed, but instead I had been also running this very nice Apache securty mod https://github.com/mitchellkrogza/apache-ultimate-bad-bot-blocker so i did not install it with the new build, and did not run it during this new test, and for 4 days nothing crashed. Here are those commands you requested. ulimit -a core file size (blocks, -c) 0 data seg size (kbytes, -d) unlimited scheduling priority (-e) 0 fi
  9. Hi ccw, Thanks for requesting I assemble the facts of this problem... I have uploaded to your link, let me know if any thing else is needed. https://upload.mtasa.com/u/744129701/MTA_Server_1.5.6_Linux_x64_Crash-190102-mtasa-forum-user-Xabahe.rar_
  10. Thanks @ccw, i'll try switching to apache 2.2 and server 1.5.6 .5 .4 .3 x64 linux next to see if it resolves my mta server crash issue. and if not i'll go back to all new and submit dumps
  11. I have experienced the same problem again, but now caused by me trying to downgrade mta linux server x64 1.5.4-6 away from an apache 2.4 conflict, where running an active apache server on the same server as your mta server causes mta to crash every few days, but not if inactive when the DNS is not set to that server, for which i downgraded my server from 1.5.6 to 1.5.4 and it still crashed, but on my downgrade to 1.5.3 our old friend netlimiter ban was back, with no changes between 1.54 and 1.53 other than the server itself. And so I cannot test if this apache error is resolved by downgrading
  12. Thank you for your quick reply and attention to the problem. It is in fact working as normal again without any problems or fixes from me. Thanks for turning it off. And I appreciate the options you add in server config to turn off all new stuff. Maybe make new features that are only important to people who know about them an option to turn it on instead. As far as I am concerned MTA was perfect 2 years ago. I will check back in for any updates on this issue in the future.
  13. That was quick: http://wiki.multitheftauto.com/wiki/Anti-cheat_guide#.3Cdisableac.3E.3C.2Fdisableac.3E But it does not list the new fixes, please enable these or list these. In game: You were kick from the game (SD #5 JHSH) Ensure no other program is modyfying MTA:SA On join: Disconnected you were kicked by (VF #4 JH8H)
  14. Apparently this problem is being caused by the MTA upgrade of 181010, on purpose. It is caused by using a bandwidth shaper, Net Limiter, or NetBalancer, because someone figured out how to cheat with it. My problem is here:
  15. I awoke to find both my pcs repeatedly kicked from my own server which I have run 24/7 for 4 years to the enjoyment of a 120k+ users. I learned lua here, i spent thousands of hours building an amazing world that has sat unchanged for several years. It is perfect. kicked, kicked, kicked, rebooted, upgraded server, reinstalled gta, mta, kicked, kicked, kicked. I live at the end of a very long road on MTA and in life, literally, I am at the edge of DSL service. If i use even half my potential bandwidth my dsl disconnects. I am a professional and require bandwidth shaping to maintain my online pre
  16. Net Limiter too!!! Okay but here is the problem, if I dont use netlimiter my DSL disconnects every single time i download anything.
  17. correct message is: Disconnected you were kicked by (VF #4 JH8H) I get the same message on other servers too NFS and CiT
  18. 181009 Pre update two different mirc while idle. You were kick from the game (SD #5 JHSH) Ensure no other program is modyfying MTA:SA Post update finished and rejoin... Disconnected you were kicked by (VF #4 JH8J) over and over Rebooted VPS, did not solve. Cannot enter my own server. I am owner, scripter, operator, admin. Server in use 2 years with no changes. Server is linux on debian 9, unknown 1.55 version number 1.52 MB (1,597,440 bytes) mta-server64 Please help updated to latest stable linux x64 1.56 no change, cannot enter server, please help. Disconnected you
  19. Several Weeks pass... No Apache. No problem.
  20. Completed another try. Built new to Debian 9.3 added MTA ran stable for many days, switched my Website DNS to that VPS and 10 hours later MTA server crashes, and again a few hours after that. And then did it all over again to CentOS 7.4 and MTA ran several days with no problem as always, then switched the DNS of my website to that VPS and MTA crashed within 12 hours, and a few hours later again, and again. No unusual web activity, MTA server is slow as typical. And Note on CentOS, last year at this time, I ran MTA, JC3MP, RageMP and 4 websites all from one VPS and the same MTA resources packag
  21. Why does MTA Server crash when I run apache2.4 on my Debian 9 and/or httpd on my CentOS 7 VPS? Stock MTA, newly built, my standard package I've run unchanged for 3 years. Stock new builds of both systems with nothing more than what was needed to start and be secure. I've Clean rebuilt it all 3 times. Three different MTA linux server builds too. Any ideas why MTA server keeps crashing? When this first occurred, but never since, i got it to crash again by rapidly clicking around on my website on that server. At least it crashed while I was doing that, thinking, can this crash it? And i
  22. Confirmed. Can you add this option?
  23. You presume there is a chat. You can. Clearly if I could. No one would have opened my admin panel by typing 'admin' This is overkill. With enabled no bind would function. My point and question stand... Despite it being overkill in your opinion's, I feel the Console represents a security threat, that is completely needless. That is to say the Console can be used by people smarter than me to do things I have enabled unknowingly to hurt me. While simultaneously the console itself serves no purpose on my server. Push F8 to exploit this noob...
  24. Last week a user rendered my server offline for 8+ hours because unlike me, he knew he could type "admin" into the console and gain access to my admin panel. Commands can be executed from Console. Consoles represent a security threat no matter how remote that may be. I have zero use for my public server to have a Console. It is a potential threat and confusing to users who do not understand what it is, who think they've broken something when they accidentally open it. The Console offers the smarter than me user opportunities, while burdening me with constant worries, that exist for absolutely
×
×
  • Create New...