Xabache

Members
  • Content Count

    133
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Xabache

  • Rank
    Poot-butt

Recent Profile Visitors

1,422 profile views
  1. Xabache

    setMoonSize(0)

    @Dutchman101 The moon was being removed by a bug, now fixed, leaving the moon, now removed by a shader, you just wrote. Thank you, it works perfectly. However, setSunSize(0) removes the Sun's disk, if not the godray, and sunlight direction. Which is nice! but.. setMoonSize(0) will never remove the Moon's disk? This seems inconsistent with both the previous sun function, and the meaning of 0 itself. I have setCloudsEnabled(false), but the stars, and Venus the big bright star, still exist. Could you create a shader or function to remove them also? And someday, setStarSize(0) or setStarsEnabled(false) might also do this ;-) @ccwYup, your old version gives me a starless, moonless night!
  2. Xabache

    setMoonSize(0)

    https://upload.mtasa.com/u/631516260/timecyc.dat_ dated 01/07/2005 likely stock
  3. Xabache

    setMoonSize(0)

    @yasin0Placing the above in my meta file, at the top, just above the client and/or server Lua file that contains set moon, this does not fix this in a fresh test server. @King12 Thanks for confirming you have this too! It has been many years since I wrote my live server from modified mta community assets leaving me to ask... @ccwHow would I check if I am using a custom timecyc.dat ? But I can say, I had not modified my server in several years. There had never been moon or stars in that time. From my in game screenshots I can verify that prior to June 26, 2019 there were no stars or moon in my night sky, and by the latest of July 02, 2019 the moon and stars are large and in charge. There is no known change of my code in that time. And regardless of the stars roll in this. it must be said if setMoonSize(0) is to function as intended, then this does not function at all at current. Where setSunSize(0) does work fine. And to the stars, that are definitely not the moon, I hope setStarSize(0) will soon follow.
  4. Xabache

    setMoonSize(0)

    For years I enjoyed a moon and star free server. For years I made no changes to my server. Why do I now have a moon? setMoonSize(0) The above, in the past two months or so, now does nothing.
  5. What happened to tow trucks. They use to be one of the funnest vehicles in the game. You could tow away an occupied car... no more. You could create a massive train of tow trucks towing other tow trucks that were towing yet more tow trucks... No more.. Why did this change? Now a tow truck can't tow an occupied car, and it cannot tow a vehicle while being itself towed. This isn't a feature. This is a bug. Please bring back our much loved tow truck, or introduce a switch that allows for old and new tow truck towing policy to be selected by the server owner. Default: Old.
  6. It appears this problem is being caused by the massive 'bad referrers' list. Can't say why. Removing it reduced the bad bots file by 85% and MTA server no longer crashes.
  7. Sorry for the delay. I rebuilt the VPS on CentOS 7.5 x64 and Apache/2.4.6, and in doing so recognized that I was not running them stock as I assumed, but instead I had been also running this very nice Apache securty mod https://github.com/mitchellkrogza/apache-ultimate-bad-bot-blocker so i did not install it with the new build, and did not run it during this new test, and for 4 days nothing crashed. Here are those commands you requested. ulimit -a core file size (blocks, -c) 0 data seg size (kbytes, -d) unlimited scheduling priority (-e) 0 file size (blocks, -f) unlimited pending signals (-i) 1864 max locked memory (kbytes, -l) 64 max memory size (kbytes, -m) unlimited open files (-n) 1024 pipe size (512 bytes, -p) 8 POSIX message queues (bytes, -q) 819200 real-time priority (-r) 0 stack size (kbytes, -s) 8192 cpu time (seconds, -t) unlimited max user processes (-u) 1864 virtual memory (kbytes, -v) unlimited file locks (-x) unlimited free total used free shared buff/cache available Mem: 498828 428924 5996 4716 63908 36272 Swap: 524284 0 524284 After the four day test of running without any crash of MTA, which is twice as a long as ever before, I again started ultimate bad bot blocker and started at 0110 0530am 36 hours later... and about 12 hours later after a crash i could not confirm was a crash.... [root@centosuw1 ~]# ps -o etimes -p 5423 ELAPSED [root@centosuw1 ~]# ps -o etimes -p 8723 ELAPSED 248 5 minutes after MTA server auto restart... [root@centosuw1 ~]# ulimit -a core file size (blocks, -c) 0 data seg size (kbytes, -d) unlimited scheduling priority (-e) 0 file size (blocks, -f) unlimited pending signals (-i) 1864 max locked memory (kbytes, -l) 64 max memory size (kbytes, -m) unlimited open files (-n) 1024 pipe size (512 bytes, -p) 8 POSIX message queues (bytes, -q) 819200 real-time priority (-r) 0 stack size (kbytes, -s) 8192 cpu time (seconds, -t) unlimited max user processes (-u) 1864 virtual memory (kbytes, -v) unlimited file locks (-x) unlimited [root@centosuw1 ~]# free total used free shared buff/cache available Mem: 498828 184844 58580 12792 255404 271068 Swap: 524284 44552 479732 [root@centosuw1 ~]# A complete collection of the logs here: https://upload.mtasa.com/u/931573179/MTA_Server_1.5.6_Linux_x64_Crash-190102-mtasa-forum-user-Xabahe2.rar_ And the very popular bad bot blocker that is apparently making mta crash by blocking something mta is doing? https://upload.mtasa.com/u/976134511/MTA_Server_1.5.6_Linux_x64_Crash-190102-mtasa-forum-user-Xabahe2-badbotblocker.rar_ My best guess is that bad bot blocker sees mta doing something it doesnt understand, and therefore it prevents mta from doing it, and mta doesnt understand why it cant do this, so it has a security measure that forces a shutdown of the server, thus leaving no dump file..
  8. Hi ccw, Thanks for requesting I assemble the facts of this problem... I have uploaded to your link, let me know if any thing else is needed. https://upload.mtasa.com/u/744129701/MTA_Server_1.5.6_Linux_x64_Crash-190102-mtasa-forum-user-Xabahe.rar_
  9. Thanks @ccw, i'll try switching to apache 2.2 and server 1.5.6 .5 .4 .3 x64 linux next to see if it resolves my mta server crash issue. and if not i'll go back to all new and submit dumps
  10. I have experienced the same problem again, but now caused by me trying to downgrade mta linux server x64 1.5.4-6 away from an apache 2.4 conflict, where running an active apache server on the same server as your mta server causes mta to crash every few days, but not if inactive when the DNS is not set to that server, for which i downgraded my server from 1.5.6 to 1.5.4 and it still crashed, but on my downgrade to 1.5.3 our old friend netlimiter ban was back, with no changes between 1.54 and 1.53 other than the server itself. And so I cannot test if this apache error is resolved by downgrading to 1.5.3. Noting the error may still be apache 2.4 versus 2.2, which i Use to run stably next to 1.5.3 and I think 1.5.4. So in linux server x64 1.5.3 joining with client windows x64 1.5.6 how might I make this evil netlimiter ban go away? I tried: <disableac>33</disableac> Which is of course not listed as being real, but also can confirm it did nothing. https://wiki.multitheftauto.com/wiki/Anti-cheat_guide#.3Cdisableac.3E.3C.2Fdisableac.3E
  11. Thank you for your quick reply and attention to the problem. It is in fact working as normal again without any problems or fixes from me. Thanks for turning it off. And I appreciate the options you add in server config to turn off all new stuff. Maybe make new features that are only important to people who know about them an option to turn it on instead. As far as I am concerned MTA was perfect 2 years ago. I will check back in for any updates on this issue in the future.
  12. That was quick: http://wiki.multitheftauto.com/wiki/Anti-cheat_guide#.3Cdisableac.3E.3C.2Fdisableac.3E But it does not list the new fixes, please enable these or list these. In game: You were kick from the game (SD #5 JHSH) Ensure no other program is modyfying MTA:SA On join: Disconnected you were kicked by (VF #4 JH8H)
  13. Apparently this problem is being caused by the MTA upgrade of 181010, on purpose. It is caused by using a bandwidth shaper, Net Limiter, or NetBalancer, because someone figured out how to cheat with it. My problem is here:
  14. I awoke to find both my pcs repeatedly kicked from my own server which I have run 24/7 for 4 years to the enjoyment of a 120k+ users. I learned lua here, i spent thousands of hours building an amazing world that has sat unchanged for several years. It is perfect. kicked, kicked, kicked, rebooted, upgraded server, reinstalled gta, mta, kicked, kicked, kicked. I live at the end of a very long road on MTA and in life, literally, I am at the edge of DSL service. If i use even half my potential bandwidth my dsl disconnects. I am a professional and require bandwidth shaping to maintain my online presence for which I use NetLimiter 4 a very nice program for limiting power hungry apps and preventing disconnects. So why must I suffer these cheat preventions if I and my community have no need for them, any of them at all? Please immediately implement a server side switch to disable any and all cheat preventions. To freeroam they are a nuisance, and to me they might just be the end of my community's road on MTA. RE: