Jump to content

Stylez

Members
  • Content Count

    85
  • Joined

  • Last visited

Everything posted by Stylez

  1. Stylez

    script help

    Nonono. i want to trigger bindKey function to client side. i tried to bind M key with "onClientPlayerVehicleEnter" but it didint worked for me, so i tried another way.
  2. Stylez

    script help

    i tried to trigger bindKey function to client side. Maybe, u can fix my code so it triggers bindKey function to clientside?
  3. Stylez

    script help

    Good Evening everybody i have this small script. You should understand what i am trying to do.. i know where i have problem. But i cant solve it the problem is in local vehicle = getPedOccupiedVehicle(source) - source argument.. but as i said, i cant solve this problem Here is the code function bind() local vehicle = getPedOccupiedVehicle(source) if vehicle then local driver = getVehicleOccupant(vehicle) if driver then bindKey(source, "m", "down", bind) triggerClientEvent(source, "bindKey", getRootElement(), "trigger")
  4. no need anymore, i just tested everything. and it works now im gonna try to make it with SQL
  5. hmm.. i edited serverside code. And now it works just like it should Here's my full code, can u look if there is any problems/fails in it? C function loginas() local sWidth, sHeight = guiGetScreenSize() local width, height = 400, 400 local x = (sWidth/2) - (width/2) local y = (sHeight/2) - (height/2) mainWin = guiCreateWindow (x,y, width, height, "Hello, Please Log-In", false) guiWindowSetMovable(mainWin, false) guiWindowSetSizable(mainWin, false) user_Label = guiCreateLabel (150, 100, 100, 50, "Username:", false, mainWin) pass_Label = guiCreateLab
  6. Oh now it works.. made a stupid mistake . btw. it dosent outputs debugscript errors into server log file
  7. there is few errors, in debugscript. Is there any way to copy the errors?
  8. oh thanks. but now, i dont understand why it doesnt creates buttons and edit fields.. everything is seems to be okey.
  9. Hi, again. So i have this login, register, guest, Gui window which should work properly but, i cant see the problem why window doesnt shows up. And there is no errors in debugscript 3 heres the code C function loginas() local sWidth, sHeight = guiGetScreenSize() local width, height = 400, 400 local x = (sWidth/2) - (width/2) local y = (sHeight/2) - (height/2) mainWin = guiCreateWindow (x,y, width, height, "Hello, Please Log-In", false) guiWindowSetMovable(mainWin, false) guiWindowSetSizable(mainWin, false) user_Label = guiCreateLabel (175, 100, 100,
  10. Stylez

    need sum help

    I dont know.. it spawns me somwhere in mountains, and shows blue sky.. It should spawn me in Grove Street and should be able to move,
  11. Stylez

    need sum help

    i removed all resources.
  12. Stylez

    need sum help

    it works now, but it doesnt spawns me, just shows blue sky.
  13. Stylez

    need sum help

    ERROR: Client triggered serverside event guestLogin, but event is not added serverside.. wut? addEvent("guestLogin", true)
  14. Stylez

    need sum help

    Hello. Im trying to make guest button. but im keep getting this error : WARNING: guset/testC.lua36: Bad argument @ AddEventHandler [Expected element a argument 2, got nil] Here is the code function myfirstwindow() local swidth, sheight = guiGetScreenSize() local width, height = 400, 400 local x = (swidth/2) - (width/2) local y = (sheight/2) - (height/2) window1 = guiCreateWindow(x, y, width, height, "Title", false) -- MAIN WINDOW guiWindowSetMovable(window1, false) guiWindowSetSizable(window1, false) --Button guestBtn = guiCreateButton(160,370,70,30, "Play as Guest", false, win
  15. but it doesnt creates button. why? i deleted 2 spaces between arguments.
  16. oh, didint saw it. thankyou
  17. hi, i made a gui script from intro. to gui scripting but i did it with absolute position and window doesnt shows up. heres the code CLIENT function createLoginWindow local sWidth, sHeight = guiGetScreenSize() local width, height = 450, 450 local x = (sWidth/2) - (width/2) local y = (sHeight/2) - (height/2) loginWindow = guiCreateWindow(x,y, width, height, "Please Log-In", false) guiWindowSetMovable (loginWindow, false) guiWindowSetSizable (loginWindow, false) guiCreateLabel(190,50,35, 25, "Username", false, loginWindow) guiCreat
  18. I think i fixed the problem i don't know how, but i did it. Here is what i did : 1. Updated MTA 1.2 version to latest 1.2 version. 2. Started server.bat typed in "start editor". 3. Deleted editor_test and _dump folders. 4. Disabled auto-save function in editor. 5. Mapped all day long without any issues.
  19. No, it doesn't. I have read about spaces in names too. The problem is that i can see all my objects in .map file but not in map editor...
  20. Hello. Few days ago i begun to map race map, i had over 2k lines of objects in my .map file when i saved the map. But next day i opened my saved map with map editor,and i saw that half of my map work was disappeared. Then i immediately opened my .map file with notepad++ to check if it contains same amount of objects. Yes, there still was 2k lines of objects. But those 2k of objects didn't appeared in map editor and map editor test mode. i was using MTA. 1.3.1 version. Then to solve this problem i searched on different forums, and i found the solution for this problem in this topic Fixing Bug
  21. Stylez

    help :?

    damn... whole day i was looking at this script and i didin't found that mistake thankyou again
  22. Stylez

    help :?

    hmm, i've got another problem now i created allmost the same script ass the 1st one, but this one shows Err. message; attempt to call global 'getPedOccupedVehicle' (a nil value) function uzkurti (thePed) local theVehicle = getPedOccupedVehicle(source) if theVehicle then if getVehicleEngineState(theVehicle, false) then setVehicleEngineState(theVehicle, true) end end end function kurti () bindKey(source,"lalt", "down", uzkurti) end addEventHandler("onPlayerVehicleEnter", getRootElement(), kurti)
×
×
  • Create New...