Jump to content

CrazyDude69

Members
  • Posts

    18
  • Joined

  • Last visited

Everything posted by CrazyDude69

  1. Sometimes still have "Segmentation fault"
  2. Ok i fixed that problem, but i have a new... When i starting server i getting ERROR: Could not start HTTP server on interface '92.63.107.70' and port '22109'! If i use 0 server starting, but noone can connect it, because of file downloading error, someone help :3
  3. Hello, when i starting my server, i getting Segmentation fault error everytime! Can you help me? Thanks...
  4. Hello everyone, each time someone tries to connect my server, he gets that errors: [attachment=0]error.PNG[/attachment] Here is server config: <config> <servername>XtremeX.tm Training Server^^</servername> <serverip>217.199.218.178</serverip> <mtusize>1264</mtusize> <serverport>22009</serverport> <maxplayers>25</maxplayers> <httpserver>0</httpserver> <httpport>22109</httpport> <httpdownloadurl></httpdownloadurl> <ase>1</ase> <donotbroadcastlan>0</donotbroadcastlan> <password></password> <logfile>../../../../mtaserver.log</logfile> <acl>acl.xml</acl> <scriptdebuglogfile>logs/scripts.log</scriptdebuglogfile> <scriptdebugloglevel>0</scriptdebugloglevel> <htmldebuglevel>0</htmldebuglevel> <fpslimit>36</fpslimit> <resource src="helpmanager" startup="1" protected="0"/> <resource src="joinquit" startup="1" protected="0"/> <resource src="defaultstats" startup="1" protected="0"/> <resource src="mapcycler" startup="1" protected="0"/> <resource src="mapmanager" startup="1" protected="0"/> <resource src="parachute" startup="1" protected="0"/> <resource src="resourcebrowser" startup="1" protected="1" default="true"/> <resource src="resourcemanager" startup="1" protected="1"/> <resource src="scoreboard" startup="1" protected="0"/> <resource src="spawnmanager" startup="1" protected="0"/> <resource src="votemanager" startup="1" protected="0"/> <resource src="webadmin" startup="1" protected="0"/> <resource src="play" startup="1" protected="0"/> <resource src="race" startup="1" protected="0"/> </config>
  5. Hello everyone! Yesterday, downloaded wiki.mtasa.com site to my computer, and now i can use it offline, i think it's allowed to post link to download wiki So you can download it http://depositfiles.com/files/oftx2selq
  6. Yea, but why here - http://wiki.mtasa.com/wiki/Vehicle "health: the vehicle's health. A value of 1000 means completely healthy, although higher values are allowed." And yes:
  7. Hello guys, i have a new problem... I have clientside function: function rendering() if (draw) then dxDrawImage(screenWidth/2-16,screenHeight/2-70,32,32,"data/cur.png") elem = getElementsByType("vehicle") for key,value in pairs(elem) do local veh = getPedOccupiedVehicle(player) if isElementOnScreen(value) and veh ~= value then local ex,ey,ez = getElementPosition(value) local px,py,pz = getElementPosition(player) local dis = getDistanceBetweenPoints3D(ex,ey,ez,px,py,pz) if dis < 50 and isLineOfSightClear(ex,ey,ez,px,py,pz,true,false,false,false) then local x,y = getScreenFromWorldPosition(ex,ey,ez) local hp = getElementHealth(value) if x and hp ~= 0 then hp = hp/10000 dxDrawRectangle(x-62.5, y, 125, 25, tocolor(0,0,0,100)) dxDrawRectangle(x-59.5, y+3, 119*hp, 19, tocolor(255,0,0,200)) end end end end end end addEventHandler("onClientRender", getRootElement(), rendering) and i have: function setHealthC(theVehicle) local vx, vy, vz = getElementPosition(theVehicle) local vrx, vry, vrz = getElementRotation(theVehicle) setElementHealth(theVehicle, 10000.0) military = createObject(3884, vx,vy,vz+1,vrx,vry,vrz) setObjectStatic(military, true) setElementCollisionsEnabled(military, false) attachElements(military, theVehicle) end addEventHandler("onClientPlayerVehicleEnter", getRootElement(), setHealthC) So there is a problem: When i enter car, and looking how many my car have health, it's write's that i have 10000 health, when i exit, now i can see that car HP bar, and it shows that this car has about 1000hp, so hp bar is not full, also when i'm in car, and other players looking at my car HP bar, they see that thing too, that hp bar is not full, only 1 time, it showed me full bar, but when i rejoined from car, i again see, that hp bar is not full, i think the problem in desync with client and server, but maybe no? I hope u will help me!
  8. Oh shit! Thank you very much, that was mistake
  9. Oh shit! Thank you very much, that was mistake
  10. hey everyone again! I have one problem, i have client-side script, i created this function: function isPedDriver( ped, vehicle ) local pedIn = GetVehicleOccupant( vehicle, 0 ) if pedIn == ped then return true else return false end end This function checks, if "ped" sitting in "vehicle" as driver (driver seat 0), if yes, returns true, if not, returns false, and yes, before i using this function, i check if player in vehicle, so when i use it, i get that in debugscript:
  11. hey everyone again! I have one problem, i have client-side script, i created this function: function isPedDriver( ped, vehicle ) local pedIn = GetVehicleOccupant( vehicle, 0 ) if pedIn == ped then return true else return false end end This function checks, if "ped" sitting in "vehicle" as driver (driver seat 0), if yes, returns true, if not, returns false, and yes, before i using this function, i check if player in vehicle, so when i use it, i get that in debugscript:
  12. Oh, i get why keys don't binding, the problem in "play" gamemode, for let them bind, i must first die, and after respawn, everything will be ok
  13. Oh, i get why keys don't binding, the problem in "play" gamemode, for let them bind, i must first die, and after respawn, everything will be ok
  14. I have function projectile, just don't posted it, this function works, so problem don't in it :\
  15. I have function projectile, just don't posted it, this function works, so problem don't in it :\
  16. Hi everyone, look at my script: http://mta.pastebay.com/82749 Why the hell, when player spawns, keys not binding? If i trigerring this function with addCommandHandler, everything is ok, but if i trigerring this with addEventHandler, nothing happens, and this is client side script, and /debugscript 3 don't see errors or warning :\ And rootElement = getRootElement()
  17. Hi everyone, look at my script: http://mta.pastebay.com/82749 Why the hell, when player spawns, keys not binding? If i trigerring this function with addCommandHandler, everything is ok, but if i trigerring this with addEventHandler, nothing happens, and this is client side script, and /debugscript 3 don't see errors or warning :\ And rootElement = getRootElement()
×
×
  • Create New...